summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNiels Thykier <niels@thykier.net>2019-10-06 10:01:49 +0000
committerNiels Thykier <niels@thykier.net>2019-10-06 10:01:49 +0000
commitebc4f4e86db129b584a88134cf2bca217435d0e3 (patch)
treeda4ad11ba233d0860e6569d6482c51dfb91fbfdc
parentf4cbe0199347b5d6a4b51941f7c104b000491f35 (diff)
downloaddebhelper-ebc4f4e86db129b584a88134cf2bca217435d0e3.tar.gz
Actively discourage (but no deprecate) c11
Signed-off-by: Niels Thykier <niels@thykier.net>
-rw-r--r--debhelper.pod8
-rw-r--r--debian/changelog4
2 files changed, 12 insertions, 0 deletions
diff --git a/debhelper.pod b/debhelper.pod
index 8ef49ce6..dcc314d9 100644
--- a/debhelper.pod
+++ b/debhelper.pod
@@ -645,6 +645,14 @@ those ~5 years, this item have been removed rather than fixed.
=item v11
+This mode is discouraged.
+
+The compat 11 is discouraged for new packages as it suffers from
+feature interaction between L<dh_installinit> and L<dh_installsystemd>
+causing services to not run correctly in some cases. Please consider
+using compatibility mode 10 or 12 instead. More details about the
+issue are available in Debian#887904.
+
Changes from v10 are:
=over 8
diff --git a/debian/changelog b/debian/changelog
index 51edd7e2..c5759294 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -9,6 +9,10 @@ debhelper (12.6.2) UNRELEASED; urgency=medium
trivial amount of manpages. Thanks to Robert Luberda for
reporting the issue and Colin Watson for writing man-recode
(Closes: #933576)
+ * debhelper.pod: Actively discourage compat 11 as it has an
+ issue that causes services not to start correctly in all cases
+ (e.g. install, remove-but-not-purge, install again), which
+ cannot be fixed.
[ Helmut Grohne ]:
* cmake buildsystem: Fix CMAKE_SYSTEM_PROCESSOR for 32bit arms.