summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortron <tron>2008-12-29 11:45:43 +0000
committertron <tron>2008-12-29 11:45:43 +0000
commit71715ca17554e6683ccd378d0944c4ce3481a059 (patch)
tree0ebd8340b56a7b7c94fff3985ecaa37845703b83
parent6a02d228149593e7a3bf537308555c171d33c349 (diff)
downloadpkgsrc-71715ca17554e6683ccd378d0944c4ce3481a059.tar.gz
Pullup ticket #2615 - requested by he
p5-SOAP-Lite: build fix Revisions pulled up: - net/p5-SOAP-Lite/Makefile 1.23 via patch --- Module Name: pkgsrc Committed By: he Date: Thu Dec 18 20:56:09 UTC 2008 Modified Files: pkgsrc/net/p5-SOAP-Lite: Makefile Log Message: Update from version 0.710.08nb2 to 0.710.08nb3. Pkgsrc changes: o Add dependency on perl>=5.10 or p5-version. When pulled up to pkgsrc-2008Q3 this should fix PR#39773.
-rw-r--r--net/p5-SOAP-Lite/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/net/p5-SOAP-Lite/Makefile b/net/p5-SOAP-Lite/Makefile
index 95fd7c9665e..392ff3ef9f1 100644
--- a/net/p5-SOAP-Lite/Makefile
+++ b/net/p5-SOAP-Lite/Makefile
@@ -1,8 +1,9 @@
-# $NetBSD: Makefile,v 1.17 2008/07/27 20:56:27 he Exp $
+# $NetBSD: Makefile,v 1.17.4.1 2008/12/29 11:45:43 tron Exp $
#
DISTNAME= SOAP-Lite-0.710.08
PKGNAME= p5-${DISTNAME:S/710.08/71.08/}
+PKGREVISION= 4
CATEGORIES= net perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=SOAP/}
@@ -14,8 +15,18 @@ COMMENT= Perl5 module providing a lightweight interface to SOAP
PKG_DESTDIR_SUPPORT= user-destdir
WRKSRC= ${WRKDIR}/${DISTNAME:C|[a-z]$||}
+
+DEPENDS+= p5-Compress-Zlib>=0:../../devel/p5-Compress-Zlib
+DEPENDS+= p5-Crypt-SSLeay>=0:../../security/p5-Crypt-SSLeay
+DEPENDS+= p5-FCGI>=0:../../www/p5-FCGI
+DEPENDS+= p5-libwww>=0:../../www/p5-libwww
+DEPENDS+= p5-IO-Socket-SSL>=0:../../security/p5-IO-Socket-SSL
DEPENDS+= p5-MIME-Base64-[0-9]*:../../converters/p5-MIME-Base64
+DEPENDS+= p5-MIME-Lite>=0:../../mail/p5-MIME-Lite
+DEPENDS+= p5-MIME-tools>=0:../../mail/p5-MIME-tools
+DEPENDS+= p5-Net>=0:../../net/p5-Net
DEPENDS+= p5-URI-[0-9]*:../../www/p5-URI
+DEPENDS+= {perl>=5.10.0,p5-version>=0}:../../devel/p5-version
DEPENDS+= p5-XML-Parser>=2.23:../../textproc/p5-XML-Parser
REPLACE_PERL+= bin/SOAPsh.pl bin/XMLRPCsh.pl bin/stubmaker.pl