summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFathi Boudra <fabo@debian.org>2011-06-10 10:29:42 +0300
committerFathi Boudra <fabo@debian.org>2011-06-10 10:29:42 +0300
commit8d094dbed27aad10b7eef5316a12e4497d61e9cb (patch)
tree1995489b33ca4cbb6406ed5fcd966916ffeb65a4
parent290508beb1b09df83a1f9bcae2a9d9b71a21b332 (diff)
downloadqt4-x11-8d094dbed27aad10b7eef5316a12e4497d61e9cb.tar.gz
Add a separate package for lupdate and lrelease: qt4-linguist-tools. (Closes: #629282)
-rw-r--r--debian/changelog2
-rw-r--r--debian/control18
-rw-r--r--debian/libqt4-dev.install2
-rw-r--r--debian/libqt4-dev.links2
-rw-r--r--debian/libqt4-dev.manpages2
-rw-r--r--debian/libqt4-dev.postinst10
-rw-r--r--debian/libqt4-dev.prerm2
-rw-r--r--debian/qt4-linguist-tools.install2
-rw-r--r--debian/qt4-linguist-tools.links2
-rw-r--r--debian/qt4-linguist-tools.manpages2
-rw-r--r--debian/qt4-linguist-tools.postinst15
-rw-r--r--debian/qt4-linguist-tools.prerm13
12 files changed, 53 insertions, 19 deletions
diff --git a/debian/changelog b/debian/changelog
index 36245f3..d7b785d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,6 +5,8 @@ qt4-x11 (4:4.7.3-2) UNRELEASED; urgency=low
* Build Qt with GL ES 2 on armel and armhf architectures:
- debian/control: add libgles2-mesa-dev | libgles2-dev build-dependencies.
- debian/rules: pass -opengl es2 configure option.
+ * Add a separate package for lupdate and lrelease: qt4-linguist-tools.
+ (Closes: #629282)
-- Fathi Boudra <fabo@debian.org> Fri, 10 Jun 2011 09:21:12 +0300
diff --git a/debian/control b/debian/control
index 15a4449..a968998 100644
--- a/debian/control
+++ b/debian/control
@@ -412,7 +412,8 @@ Depends: ${shlibs:Depends}, ${misc:Depends}, libqtcore4 (= ${binary:Version}),
libqt4-scripttools (= ${binary:Version}), libqt4-xmlpatterns (= ${binary:Version}),
libqt4-qt3support (= ${binary:Version}), libqt4-designer (= ${binary:Version}),
libqt4-help (= ${binary:Version}), libqt4-test (= ${binary:Version}),
- libqt4-declarative (= ${binary:Version}), qt4-qmake (= ${binary:Version})
+ libqt4-declarative (= ${binary:Version}), qt4-qmake (= ${binary:Version}),
+ qt4-linguist-tools (= ${binary:Version})
Recommends: libqt4-opengl-dev (= ${binary:Version}), libqtwebkit-dev (>= 2.0~)
Breaks: libqtwebkit-dev (<< 2.0~), libqt4-opengl-dev (<< 4.4.0-2), g++-4.6 (<< 4.6.0-7~) [armel]
Replaces: libqtwebkit-dev (<< 2.0~), libqt4-opengl-dev (<< 4.4.0-2)
@@ -580,6 +581,21 @@ Description: Qt 4 QML viewer
.
This package contains Qt 4 QML viewer (qml). It allows to view QML files.
+Package: qt4-linguist-tools
+Architecture: any
+Section: devel
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Breaks: libqt4-dev (<< 4.7.3-2)
+Replaces: libqt4-dev (<< 4.7.3-2)
+Description: Qt 4 Linguist tools
+ Qt is a cross-platform C++ application framework. Qt's primary feature
+ is its rich set of widgets that provide standard GUI functionality.
+ .
+ This package contains lupdate and lrelease. lupdate is a command line tool
+ that finds the translatable strings in the specified source, header and
+ Qt Designer interface files, and produces or updates .ts translation files.
+ lrelease is a command line tool that produces QM files out of TS files.
+
Package: qt4-doc
Architecture: all
Section: doc
diff --git a/debian/libqt4-dev.install b/debian/libqt4-dev.install
index 5f1b663..dcd7253 100644
--- a/debian/libqt4-dev.install
+++ b/debian/libqt4-dev.install
@@ -1,5 +1,3 @@
-usr/bin/lrelease-qt4
-usr/bin/lupdate-qt4
usr/bin/moc-qt4
usr/bin/qdbuscpp2xml
usr/bin/qdbusxml2cpp
diff --git a/debian/libqt4-dev.links b/debian/libqt4-dev.links
index a5f0272..f9230c4 100644
--- a/debian/libqt4-dev.links
+++ b/debian/libqt4-dev.links
@@ -1,6 +1,4 @@
usr/include/qt4 usr/share/qt4/include
-usr/bin/lrelease-qt4 usr/share/qt4/bin/lrelease
-usr/bin/lupdate-qt4 usr/share/qt4/bin/lupdate
usr/bin/moc-qt4 usr/share/qt4/bin/moc
usr/bin/uic-qt4 usr/share/qt4/bin/uic
usr/bin/rcc usr/share/qt4/bin/rcc
diff --git a/debian/libqt4-dev.manpages b/debian/libqt4-dev.manpages
index 5750068..644bed7 100644
--- a/debian/libqt4-dev.manpages
+++ b/debian/libqt4-dev.manpages
@@ -1,3 +1 @@
-debian/manpages/lrelease-qt4.1
-debian/manpages/lupdate-qt4.1
debian/manpages/moc-qt4.1
diff --git a/debian/libqt4-dev.postinst b/debian/libqt4-dev.postinst
index e730b69..9e3c347 100644
--- a/debian/libqt4-dev.postinst
+++ b/debian/libqt4-dev.postinst
@@ -12,14 +12,4 @@ update-alternatives --install \
--slave /usr/share/man/man1/uic.1.gz uic.1.gz \
"/usr/share/man/man1/uic-qt4.1.gz"
-update-alternatives --install \
- /usr/bin/lupdate lupdate "/usr/bin/lupdate-qt4" "40" \
- --slave /usr/share/man/man1/lupdate.1.gz lupdate.1.gz \
- "/usr/share/man/man1/lupdate-qt4.1.gz"
-
-update-alternatives --install \
- /usr/bin/lrelease lrelease "/usr/bin/lrelease-qt4" "40" \
- --slave /usr/share/man/man1/lrelease.1.gz lrelease.1.gz \
- "/usr/share/man/man1/lrelease-qt4.1.gz"
-
#DEBHELPER#
diff --git a/debian/libqt4-dev.prerm b/debian/libqt4-dev.prerm
index 2c5ba05..d822876 100644
--- a/debian/libqt4-dev.prerm
+++ b/debian/libqt4-dev.prerm
@@ -7,8 +7,6 @@ case "$1" in
remove|failed-upgrade|deconfigure)
update-alternatives --remove moc "/usr/bin/moc-qt4"
update-alternatives --remove uic "/usr/bin/uic-qt4"
- update-alternatives --remove lupdate "/usr/bin/lupdate-qt4"
- update-alternatives --remove lrelease "/usr/bin/lrelease-qt4"
;;
esac
diff --git a/debian/qt4-linguist-tools.install b/debian/qt4-linguist-tools.install
new file mode 100644
index 0000000..d1e531b
--- /dev/null
+++ b/debian/qt4-linguist-tools.install
@@ -0,0 +1,2 @@
+usr/bin/lrelease-qt4
+usr/bin/lupdate-qt4
diff --git a/debian/qt4-linguist-tools.links b/debian/qt4-linguist-tools.links
new file mode 100644
index 0000000..d78d5ed
--- /dev/null
+++ b/debian/qt4-linguist-tools.links
@@ -0,0 +1,2 @@
+usr/bin/lrelease-qt4 usr/share/qt4/bin/lrelease
+usr/bin/lupdate-qt4 usr/share/qt4/bin/lupdate
diff --git a/debian/qt4-linguist-tools.manpages b/debian/qt4-linguist-tools.manpages
new file mode 100644
index 0000000..8470ed1
--- /dev/null
+++ b/debian/qt4-linguist-tools.manpages
@@ -0,0 +1,2 @@
+debian/manpages/lrelease-qt4.1
+debian/manpages/lupdate-qt4.1
diff --git a/debian/qt4-linguist-tools.postinst b/debian/qt4-linguist-tools.postinst
new file mode 100644
index 0000000..affde57
--- /dev/null
+++ b/debian/qt4-linguist-tools.postinst
@@ -0,0 +1,15 @@
+#!/bin/sh
+
+set -e
+
+update-alternatives --install \
+ /usr/bin/lupdate lupdate "/usr/bin/lupdate-qt4" "40" \
+ --slave /usr/share/man/man1/lupdate.1.gz lupdate.1.gz \
+ "/usr/share/man/man1/lupdate-qt4.1.gz"
+
+update-alternatives --install \
+ /usr/bin/lrelease lrelease "/usr/bin/lrelease-qt4" "40" \
+ --slave /usr/share/man/man1/lrelease.1.gz lrelease.1.gz \
+ "/usr/share/man/man1/lrelease-qt4.1.gz"
+
+#DEBHELPER#
diff --git a/debian/qt4-linguist-tools.prerm b/debian/qt4-linguist-tools.prerm
new file mode 100644
index 0000000..350c6eb
--- /dev/null
+++ b/debian/qt4-linguist-tools.prerm
@@ -0,0 +1,13 @@
+#!/bin/sh
+
+set -e
+
+case "$1" in
+ upgrade) ;;
+ remove|failed-upgrade|deconfigure)
+ update-alternatives --remove lupdate "/usr/bin/lupdate-qt4"
+ update-alternatives --remove lrelease "/usr/bin/lrelease-qt4"
+ ;;
+esac
+
+#DEBHELPER#